XmlBeanUtils 1.0.1 Release – Legacy parser support

For those who read my blog, I released an open-source project a couple of days ago for working with XML using DynaBeans from BeanUtils.

Today, while working with XML directly, I discovered that some older XML parsers, such as older versions of the Xerces parser, do not actually support all of the methods of Node that are required. Here’s a comparison:
Java 1.4 – Node
Java 1.5 – Node

To help deal with this, I’ve released a new version of XmlBeanUtils today with support for legacy XML parsers.

I’ve also gone through and added javadoc. My next step will be to put it up on a maven repository, that should be coming in the next few days but I probably won’t post a notification so keep an eye on the XmlBeanUtils site.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s